apt-get 提示 "E: 无法找到获取软件包的渠道 ..."

问题

执行

apt-get update && apt-get dist-upgrade -y
进行系统更新的时候发生了错误,提示信息
正在读取软件包列表... 完成
E: 无法找到获取软件包的渠道 /usr/lib/apt/methods/https 所需的驱动程序。
N: 请检查是否安装了 apt-transport-https 软件包
根据提示安执行安装命令
apt-get install apt-transport-https
依然报错
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列【新】软件包将被安装:
  apt-transport-https
升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 165 kB 的归档。
解压缩后会消耗 237 kB 的额外空间。
E: 无法找到获取软件包的渠道 /usr/lib/apt/methods/https 所需的驱动程序。
N: 请检查是否安装了 apt-transport-https 软件包

解决

在互联网搜索相关问题,发现已经有小伙伴提供了解决方法,执行命令

aptitude show apt-transport-https
显示了详细信息
软件包:apt-transport-https      
版本号:1.3~rc2
状态: 未安装
优先级:可选
部分:admin
维护者:APT Development Team <deity@lists.debian.org>
体系:amd64
未压缩尺寸:237 k
依赖于: libapt-pkg5.0 (>= 1.3~rc2), libc6 (>= 2.14), libcurl3-gnutls (>= 7.16.2), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2)
推荐: ca-certificates
冲突: apt-transport-https:i386
描述:https download transport for APT
 This package enables the usage of 'deb https://foo distro main' lines in the /etc/apt/sources.list so that all package managers using the libapt-pkg library can access metadata and packages available in sources accessible over https
 (Hypertext Transfer Protocol Secure). 
 
 This transport supports server as well as client authentication with certificates.
标签: admin::package-management, protocol::http, protocol::ssl, role::shared-lib, suite::debian, use::downloading
尝试下载并安装这个软件包
wget http://ftp.hk.debian.org/debian/pool/main/a/apt/apt-transport-https_1.0.9.8.3_amd64.deb
dpkg -i apt-transport-https_1.0.9.8.3_amd64.deb
然而报错
(正在读取数据库 ... 系统当前共安装有 334763 个文件和目录。)
正准备解包 apt-transport-https_1.0.9.8.3_amd64.deb  ...
正在将 apt-transport-https (1.0.9.8.3) 解包到 (1.0.9.8.3) 上 ...
dpkg: 依赖关系问题使得 apt-transport-https 的配置工作不能继续:
 apt-transport-https 依赖于 libapt-pkg4.12 (>= 1.0.9.8.3);然而:
  未安装软件包 libapt-pkg4.12。

dpkg: 处理软件包 apt-transport-https (--install)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 apt-transport-https
缺少依赖,先解决依赖问题,安装这个依赖包
apt-get install libapt-pkg-dev
报错
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
 apt-transport-https : 依赖: libapt-pkg4.12 (>= 1.0.9.8.3) 但无法安装它
 libapt-pkg-dev : 依赖: libapt-inst (= 1.3~rc4)
                  依赖: libapt-pkg (= 1.3~rc4)
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
根据提示,执行命令
apt-get install -f
依赖问题解决,然后执行更新操作
apt-get update
更新成功,问题解决
命中:1 http://mirrors.neusoft.edu.cn/kali kali-rolling InRelease
获取:2 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling InRelease [30.5 kB]
获取:3 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/main amd64 Packages [14.0 MB]
获取:4 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/main i386 Packages [13.9 MB]
获取:5 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/non-free amd64 Packages [154 kB]
获取:6 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/non-free i386 Packages [139 kB]
获取:7 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/contrib amd64 Packages [95.4 kB]                                                                                                                                               
获取:8 https://mirrors.tuna.tsinghua.edu.cn/kali kali-rolling/contrib i386 Packages [91.6 kB]                                                                                                                                                
已下载 28.4 MB,耗时 6秒 (4,580 kB/s)                                                                                                                                                                                                        
正在读取软件包列表... 完成

参考

http://debian-mate.lofter.com/post/1e13a9c6_b0be60f


本文链接:https://www.92ez.com/?action=show&id=23404
!!! 转载请先联系non3gov@gmail.com授权并在显著位置注明作者和原文链接 !!! 小黑屋
提示:技术文章有一定的时效性,请先确认是否适用你当前的系统环境。

上一篇: 某公司用ThinkPHP改的商城存在的支付漏洞
下一篇: 使用Python管理小米路由器

访客评论
目前还没有人评论,您发表点看法?